Custom Animations still following pattern of run animaions?

Hey y’all! I made a sprinting animation for when you hold shift. It works fine, except the fact that the character’s body movement overall follows their standard running animation.
Changing your default run animation changes your movement. How can I fix this?

1 Like

May I suggest you look at animation priorities.


Set priority to movement, and if you’re still having this issue, it was a similar issue my team and I faced, which you can find a link to here.

Heyo! This was the solution. I actually tried setting it from action to movement last night, and it didn’t work. Woke up this morning and realized it’s because the game had to wait for roblox to approve the new animation I believe, as it usually takes about 20 minutes or so for my animations to appear in game. Anyways, have a solution mark and a nice day.

1 Like

Glad I could help in the slightest, thanks! :slight_smile:

1 Like