Custom character animations not working?

I’ve been trying to create a script that transforms you into a preset character that I’ve made. The problem is that the animations don’t play.

The first thing I tried was adding an Animate script (local version), but it the model ends up looking frozen in place.

module.transform = function(player)

	local c = PresetCharacter:Clone()
	c.Name = character.Name
	player.Character = c
	c.Parent = workspace
	local newScript = AnimateScript:Clone()
	newScript.Parent = c
	newScript.Disabled = false

I also tried adding a normal Animate script (server version) by CleverSource, but the end result is working animations, but delayed. Any tips would help!

Hello, did you make sure that you animated with motor6d?

I didn’t know you could set the player’s character. Maybe check if that is valid. Or just go into test mode and copy the animate script from your character then paste it and just clone it into the character.

1 Like

Found out that I was using an incorrect Animate script. Oh well :confused: