Custom Character's Walk Animation doesn't replicate to other clients

Hi! I’m currently in the process of making a game with custom characters, and so far all works well except for one animation on a very specific character, which does not replicate to other clients. I’ve scoured multiple other Devforum articles for solutions, yet I have not found any.
I also use the default Animate script, with the ids swapped out on both the dictionary inside the script and the values inside it.
Keep in mind that all other characters and animations work just fine. It’s just the walk/run animation on this one that refuses to work, despite things like the idle working perfectly fine.

Things I have tried and know aren’t the problem;

  • Reuploading the animation (not moderated, animation preview works, i own the game and the animation, no groups are involved.)
  • Uploading the animation with priority set to Movement
  • Removing the Animator and re-making it on the server (upon character creation)
  • Modifying the default Animate script in order to use Animator:LoadAnimation() instead of Humanoid:LoadAnimation()

Any help would be much appreciated.

1 Like

Are you using the same animation ID for both run and walk animations?
I had this exact same situation using the same ID for both. Simple fix was to upload the animation again and use different IDs for both animations.


This somehow worked, despite being a bit of a dumb solution, lol. My struggles are now finally over. I’m not quite sure why Roblox doesn’t like me using the same ID for both, but it is what it is.

Thank you!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.