Custom cursor problem

Hello, I am having issue with my custom cursor script this is my code:

local uis = game:GetService("UserInputService")
local rs = game:GetService('RunService')

	uis.MouseIcon = "rbxassetid://14481912515"

I have put the script in StarterGui and it’s supposed to work as I am not using the :GetMouse() option as It’s deprecated. But, when I join the game, instead it does this:

That is not my custom cursor! Can someone try to help me fix this issue? Thanks.
Any suggestions are appreciated


Is this a local script or a script?

The script is a LocalScript, and as I said in StarterGui.

I don’t think :GetMouse() is deprecated, and you don’t need a RenderStepped connection either.

player:GetMouse().Icon = "rbxassetid://14481912515"

Is this what you are trying to accomplish? How to make a Custom Cursor

1 Like

It actually is, I tried that method and it showed the default cursor. It’s better using UserInputService.

Are you sure you did it properly? Because I use :GetMouse() for my games, and it works perfectly fine.

This works for me, put the local script in starterplayerscripts;

game.Players.LocalPlayer:GetMouse().Icon = "rbxassetid://11877973791"

Change the ID to urs, i just used EDP

Or u can use UIS

local uis = game:GetService("UserInputService")
uis.MouseIcon = "rbxassetid://11877973791"

@OnlyJ0nathan Have you looked at this?

Yes, I have looked at it but I am trying to find a simple way.

It’s like 3 lines though? Or do you mean you want a more efficient method?

I am currently looking at this.

This one doesn’t even work, I don’t even know why, I tried all methods.

Put it into starterplayerscripts

I did, it still doesn’t work, it still shows that cursor.

Are u sure the Id is valid?

Try this one then

local uis = game:GetService("UserInputService")
uis.MouseIcon = "rbxassetid://YOUR_ID_HERE"

And make sure its correct rbxassetid://YOUR_ID_HERE
The format may be wrong for u

Where do I put the LocalScript?

To my knowledge the mouse icon variable no longer works and is depricated

StarterPlayerScripts worked for me

Maybe removing RenderStepped will fix the problem?