Custom idle animation not functioning

Good Morning Everyone,

I am trying to set the player’s idle animation to the ninja idle animation by default.

What I have done is copy the Animate script from my character ingame and paste it into StarterCharacterScripts.
I then proceeded to change the AnimationId in the script and the id of script.idle.Animation1 .

I have deleted Animation2 as it is just the animation for the character to occasionally look around—which I do not want. (Keeping this didn’t affect the issue anyways.) The weight value is set to 10.

The problem is, the animation doesn’t play at all; I have no errors.

I have looked around the forums and google but can’t find any issues like this… does anyone have any ideas?


1 Like

RIP, I have the exact same problem.

1 Like

You shouldn’t enter the bundle’s ID. It just shows how it works.


This is correct I guess.

As I replied to @koziahss a few minutes ago, you should use the animation which they are using.

1 Like

Do you own this animation?

You have to own the animation from others to be able to play it. I’m not sure if this applies to ROBLOX’s stuff.

No, you don’t have to own the animation. I believe Roblox won’t be looking through at this point if you use it in your game. Bundles are preferences for players. Try the animation ID I gave you above.

Thanks, it worked!
May I ask how you would retrieve the actual animation ids from the bundle? I want to add some other animations from the catalog too.

This is nearly impossible to get it without an extension called BTR extension.

When you get it, go to the bundle you want to use and you will see a download button.

Press that button and you will see a notepad. Open it. Find the lines I gave you below.

<string name="Name">idle</string>

<Content name="AnimationId"><url></url></Content>

NOTE: There is actually more than 1 link to the animation IDs. Choose whatever you want to use for your character.

<string name="Name">pose</string>

As you can see in the line, there is a string called pose. Well, this is animation as well but it just makes the character pose.

Copy the URL link, which is inside the content name line.

This is also correct.


NOTE: This is only for bundles. There is a better way to do that for emotes.

1 Like

Thanks heaps, the extension worked flawlessly.
Roblox should really streamline this process :grin: