Custom named links inputted manually need https:// to work

When manually naming a link to something that fits better than a URL using the [name](link) format, the link path is redirected to a blank anchor element. However, using the button on the input toolbar above the text field works.

Update: Apparently links now require “https://” to work however I’m still calling this a bug.

Example:
[Test](devforum.roblox.com) Test
using https:// Test
barebones link without https:// devforum.roblox.com

First noticed it happening around 16:30 EST

1 Like

Have you tried putting https:// before the link?

When I tried doing a link with the button to roblox.com, it automatically inserted https:// before it so it might be the issue.

1 Like

This did seem to fix it. Still leaving this up with added info as this was not historically the case.

That is more than likely a discourse safety feature. It is to make sure that users don’t get accidentally redirected to unsafe websites.

6 Likes

This is just how markdown works. When you don’t add https it doesn’t know to connect to a new site. So [Test](x.com) while on y.com would bring you to y.com/x.com. This is because markdown is used frequently to access other parts of the local site. This makes it easy to direct someone to another place within the same site and is built in to markdown itself.

5 Likes

cc @steven4547466

If this was the case, then why are links that are not named allowed to be inserted without https://?

At this point I’m not sure if it’s a bug or a new feature, still waiting for staff input.

Elaborate?

Turns out when you type a link without https:// it automatically adds it in.

Changed the solution on this thread to the correct one to avoid confusion if people find this thread in the future.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.