Custom R15 character with animate script has delay in animations?

Hello everyone :slight_smile: , so I made an R15 morph, of another player character, and I’ve been told to change the animate local script to a script and delete the local player parts.
It works fine, but the problem is that when I walk or jump, there’s a delay in the animations.
I don’t know what exactly to try. I’ve tried looking for it, but didn’t find anything.
This is just the default animate script, but a script without the local player parts.
What it should be:
robloxapp-20200621-1312032.wmv (1021.0 KB)
The delay:
robloxapp-20200621-1312329.wmv (1.4 MB)

Does anyone know how to fix that?


This happens because you changed the LocalScript to a Script. By doing so, you’re basically forcing the server to do all the animations and stuff. This is not recommended, as this delay appears. The Animate localscript should always remain as a localscript, since animations played on a Player’s Humanoid will replicate to the server.

This delay is only local; only you experience it in your character, and players with this morphing will also experience it, but only on their character. In other words, you can’t see the delay of the other morphed charaters. (or at least that’s the theory)

I don’t really know why they told you to convert it into a server side script? And I don’t really understand the “delete the local player parts” - are you deleting them from client? from server? what? how? when? who am I? who are we? what means to be aliv- you get the point; more information would be cool.

For now, try to put the code of the Animate script in a LocalScript, lmk if it breaks or something.

sorry for the high edit count, I always like to put information and be descriptive - I’m not a monster


Thanks for answering, I thought that about the server too, but it just didn’t work as a local script. I followed what they told me and it worked, except for the delay. I can send you the topic link if that’s needed :blush:.

1 Like

I think I found the solution, I’ll check soon. I think the problem was that the local script was in a place that it can’t run, so the animations didn’t load.