Custom Rig Animations Not Working

Heya, I recently imported a custom rig into Roblox. I’m trying to load a simple idle animation sequence onto the rig.

The issue is that everything looks fine when I run the animation on the rig using the Animation Editor. But the moment I run the game, the NPC doesn’t have the animation loaded.


Screen_Recording_2022-06-24_at_11_52_06_AM_AdobeExpress (1)

After :nail_care: (in-game):

Obviously, not much of a result. I’ve tried quite a few things, such as:

  • Anchoring the HumanoidRootPart and vice versa,

  • Making multiple other animations,

  • Trying the animation script on other rigs (note: the ‘yellow-sponge-thing’ used as the player’s character works using the same code as the ‘rich-crab-man’, however unlike him the animation works just fine.),

  • Looping the animation from the script as well as looping the animation from the Animation Editor,

  • probably more stuff…

Below is a photograph of the rigs contents:

Screen Shot 2022-06-24 at 12.37.45 PM

And here’s the code for the animation script:

local humanoid = script.Parent:WaitForChild("Humanoid")
local animator = humanoid:WaitForChild("Animator")
local Animation = script:WaitForChild("Animation")

local LoadedAnim = animator:LoadAnimation(Animation)


Anywho, thanks :sponge:!

What’s the animation priority?

It’s using ‘Action’ priority, it’s also important for me to note that there aren’t any other animations running on the rig.

Experiment with other priorities, see if any of them work.

Woops, turns out Core priority works just fine. Thx!