Cyclic tables permitted in studio but not online

In play solo, sending cyclic tables is allowed, but in online it is not allowed. I had to debug a large system that used these because everything worked fine in play solo and I didn’t test in online until relatively late in the system’s development.

local a = {}
local b = {}

a["Next"] = b
b["Next"] = a

local r ="RemoteEvent",workspace)

Observed: the code errors in online but does not error in play solo
Expected: the code errors in play solo

1 Like

I made the same reply on your other post where you discovered this:

Have you tried in Test Server too? It is the difference between a bug with studio in general vs. a bug with Play Solo only. Might help whoever reads these to isolate the issue.

test servers have the same behavior as play solo. I haven’t specifically verified this, but I did perform some tests of the system using test servers – the system fails completely without cyclic tables, so the fact that the system worked under test servers is a strong indicator that the problem exists there as well.

Fair enough. Probably worth including that in the bug report instead of just talking about Play Solo then - again, might help the person fixing the bug :slightly_smiling_face:

1 Like

Looks like this bug has already been reported