Cylinder and sphere parts deform when unioned

I’m aware this is the wrong category, but I don’t have access to bug reports.

Regardless, as of today I have been experiencing an issue where cylinders and spheres heavily deform when unioned. Previously existing unions are fine, but new ones completely break.

The following is the result of individually unioning a sphere and cylinder, but the issue also occurs when unioning several of these parts together, making piping and other complex shapes impossible.


Normal parts and wedges are unaffected by this issue, but given the circumstances I simply cannot continue building things in Studio. Hoping this gets fixed as soon as possible.


Thank you for reporting this. I’ve seen others ask about this issue in many places aswell recently.

1 Like

Set the RenderFidelity to precise in properties.


While this may remedy the problem, setting the RenderFidelity for every single union is not a good solution as it completely interrupts the workflow of a person.

it’s still a solution though. not fair to ghost it because you don’t want to take the extra step.

1 Like

Respectfully, I disagree. I shouldn’t have to use lengthy workarounds for basic Studio functions to work properly. This isn’t the first time this bug has popped up either, I can’t help but grow tired of it.


it’s not a “lengthy workaround”, it’s a rendering parameter that has an automatic setting. clicking twice isn’t a labor intensive process. he provided a solution as to fixing your issue and you are not marking his response as a solution because you think that it takes too long to change a property. if it’s an entire model just run a command bar script.

it’s not a bug either, it’s an optimization process that roblox has implemented to downgrade mesh and union resolution based on distance and triangle count. high resolution models imported from other games require their render options to be changed to adjust to this problem because they have high vertice counts.

1 Like

I understand where you’re coming from, and after going through my recent work, it would appear that the RenderFidelity is set to Precise for everything. However, I did not manually change this setting by any means, so I’m curious to know why new unions now default to Automatic despite its appearance.


Hello and thank you very much for sharing! Could you, please, share your place file so we could try to reproduce?

I’d also suggest checking the following: Studio Settings → Rendering → Set Mesh Detail Level to DistanceBased.
That might fix the problem if Mesh Detail Level is not set to DistanceBased.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.