Darker color on certain faces of mesh

I’ve been recently learning 3D modeling in blender and tried making some models to practice.

I made this sofa model which looks fine in any 3D viewer but for some reason some of its faces become darker when imported in studio.

Correct appearance:

As you can see some of the faces become of a darker blue while the color I chose is light blue.

If it is of any importance I have DoubleSided on because otherwise some faces do not appear.


That’s ambient occlusion. It’s basically just a shadow. Can’t turn it off unless you reduce your graphics level.

Hm but it doesn’t make sense that a side is completely darker.

Oh, I thought you were talking about the dark spots here:

If you’re talking about the darker color of the armrest, it could be a normal or texture issue. Can you check your normals/textures and see if there’s anything wrong with that?

I applied a material in blender, but i don’t know if it could be causing this issue. These are the normals of the armrest

Have you marked sharp edges properly?

Never use DoubleSided as a fix to make ‘invisible’ sections appear. It’s only good use is for making flat items like leaves or paper.

There are a few issues:

  • You’ve made the Mesh with inverted Normals for some faces. For Blender go online and you can research ‘Blender show normals’. There are a few different ways to do it, and many tutorials which explain it better than I can. Your armrest normals look like they are all facing inward which reverses the shading applied. Also you have a whole lot more faces than you need in the center and the straight edges of the cushion which you could probably clean up.

  • DoubleSided fixes showing the faces, but it completely messes up lighting and shadows where edges of these faces join each other. The lighting issue you have is probably from normal facing items being lit one way and inverted faces being lit from the other side.

  • DoubleSided also doubles the amount of faces (tris) in your mesh that have to be rendered in Roblox, which may add to the workload (lag) created on your device.

Do I have to invert the normals? I think the extra faces are due to the subdivision surface modifier I applied to make the edges rounded, is there a better way?

If you have inverted Normals then your Mesh is broken. Any one of the tutorials you could have looked at would say the same as I am about to.

In Edit mode, press Ctrl A to select all faces, then go to the Mesh Menu, click Normals, then click Recalculate outside (or inside) and it should get all the faces pointing the same direction.

If you have a long straight edge of a cushion that’s curved and you have a whole bunch of faces that could be combined into one you can select the vertices you want to join up and select the one you want them to join to last, click M, then click L. This will merge all the vertices you chose at the last one you chose.

I did this and it fixed the missing faces but the dark color issue is still happening.

Its a common issue with blenders older shade smooth option. you’ll need to do Auto Shade Smooth and dont set the angle to 100.

What happens when you remove the Texture?

Another thing is try selecting all faces.
Mesh > Normals > Reset Vectors (I think that’s the name).

This resets the way the edges, vertices, and faces react to lighting.