DataStore Requests Failure

Hi. So, my game was working just fine, but all of sudden these errors keep appearing though I haven’t touched the data script for like ages ago, it’s still the same.

image

Is anyone able to tell me if this is a roblox issue itself or something like that?

HTTP 503 is a server error.

(5 = server, 4 = client)

I believe you can’t solve this because it is Roblox’s fault but I am checking other causes.

Edit: @Avanthyst do you mind sharing the code?

Hello!
You either don’t have the permission to send requests to this http or the server have a problem (I think)
I think you should wait like Shadow said above me, and share the code to see if there’s any errors

Try activating the HTTP Services.

It’s datastore service, maybe turn on studio access api services.

503 means server is active but just needs to wait, either

  • Send less requests
  • Just wait for a while and try again (1 hour wait)

It’s really weird, all my game datastores are sudden throwing up this error but they always worked fine. I’ma just guess this is a roblox issue.

Do you use the same datastore module?

It’s not, you forgot to activate the HTTP Services, try activating that.
If you already activated it, it’s weird, it looks like you didn’t.

It’s DataStore, not HTTP Services

I got the same problem 2 days ago, you just gotta wait, it doesn’t make dataloss but takes a while to load, if there’s a loop for loading the datastore and the loop is < 6 seconds, you should remove it because roblox can’t check the same user under 6 seconds