DataStore2 not saving?

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? I want DataStore2 to save.

  2. What is the issue? It won’t save. Before leaving where cash is incremented vs After rejoining where cash is reset to default.

  3. What solutions have you tried so far? I have tried adding print statements to the :Set() function of the DataStore2 module. It says that everything’s working perfectly fine, except when I rejoin, it all goes back to default.

You should probably ask any questions on the related thread here:

Otherwise, I would recommend just using DataStores without a module as there’s no need to use one.

Can we see the code? So I can tell you what’s wrong
Did you use Increment() for the Currency?

I apologise for any time wasted, problem was fixed by updating the scripts to version 1.4.0.

1 Like

I recommend doing this to be updated to the lastest version.

local DataStore2 = require( ) -- the id of the DataStore2 model
1 Like

Will do that, thanks!