Debug watches are not working correctly

Roblox Studio Debug watches always return “Symbol “” not in scope”

Tried out the example given in documentation, still says the same thing.

I already tried playing with F5, and using local script.

I even tried it on my laptop with a different account hoping it might have been my Roblox studio install or a broken plugin.

Debugging is enabled in studio settings.

Highlighting the var and then pressing “add watch” also returns the same issue.

Please help, I want to get away from adding print()s to read vars.

1 Like

Hi, sorry I can’t really help other than assuring you that

a) the debugger “works”


b) you’re not alone

I remember having issues getting it to work the other day, but I don’t remember what I did to fix it :c

Try defining the watch at some point when the variable is in scope? I know it should automatically update when it comes into scope (and it does work like that for me, right now at least), but anything is worth a try I guess.

EDIT: For now, as long as you only need to watch variables and not expressions, you can use the Local and Global tabs of the Watch window to see variables that are in scope.

Sorry for the old response but it seems like in your screenshot, you did not put a breakpoint.
And in your script window, I don’t see the yellow arrow pointing where the script is paused.

It is “Not in scope” as in it doesn’t know where to get the values from.
When you pause inside the code, now, it will know where it is.

Also, there’s also debug log points.

For more information, look up call stacks and how they store variables.

1 Like