Default animation still playing after default Animate script removal

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    For some reason, the default “looking around” animation still plays even after replacing the default Animate script with an edited one.
  2. What is the issue? Include screenshots / videos if possible!

    The running animation (which is still the default one) gets interrupted by the default “looking around” idle animation causing the running animation to stop playing.
  3. What solutions have you tried so far?
    I thought that maybe it was because the default animations started playing after loading the character and never stopped (looped animations). But when I print the amount of running animations after loading the character, the result is always 0:
game.Players.CharacterAutoLoads = false

	local description = game:GetService("ReplicatedStorage").HumanoidDescription
	local character = player.Character
	-- Custom animation located in StarterCharacterScripts
	local AnimationTracks = player.Character.Humanoid:GetPlayingAnimationTracks()
	print("amount:" .. #AnimationTracks)
	-- Stop all playing animations
	for i, t in pairs (AnimationTracks) do
	local weapon = game:GetService("ServerStorage"):WaitForChild("Weapon"):Clone()
	weapon.Parent = character
	weld(character["RightHand"], weapon)

I also removed the “no tool animation” because I thought it could have been associated with this instead of idle, but the problem remained.
This is the edited Animate script: (was taken before removing no tool animation)

All I did was replacing the default idle animations with my own in the script.

Does anyone know where this default animation is coming from? I did notice a folder being created probably because of LoadCharacterWithHumanoidDescription? It still has the default animations even after I set it to my own animation id (but the animation id inside CustomAnimate script is correct).


Set Animation 2 to the same animation and the default looking will be changed to that.


Just tried it out but the animation still plays :frowning:

1 Like

Found the answer by reading through another post. Renaming CustomAnimate (located in StarterCharacterScripts) to Animate caused the default Animate to be automatically replaced.

Thanks! @Legoracer