DepthOfField not working

Hi! I’m new to the DevFourm and something isn’t working.
I enabled DepthOfField but it’s only working in studio.
Is it not working or it’s not supposed to?


Considering that the DepthOfField effect is quite new, it wouldn’t be suprising that it hasn’t been enabled in live games yet. Although I’m not certain, this period of half release might be useful for Roblox since they can get feedback and bug reports on the new feature, allowing them to fully release a better and more stable product.


Thanks! I will wait until it comes out.

1 Like

It is still not working for me, please help!

Are you sure you have the graphics level set to high?
Does your graphics card support DX11, Metal, Vulkan?
It’s only happening to users who don’t have support to any of these above or never tried setting graphics level to high
If it’s was disabled silently, how could I know from my perspective when my graphics card does not support any of these?


Please don’t bump old topics that don’t relate to the problem that you are having. This post is regarding the beta feature not being released which it is now.

DoF was released long ago lol, it should be working now

You’re wrong there, actually. Depth of field is live and has been live for a few months. It simply doesn’t work with lower graphics. And sometimes the difference in-game or in-studio is hard to notice because of the FarIntensity of the effect.