Developer Products won't work

Hi, I have been trying to upload dev products and whenever I upload them, it says something about the image failing to load.

That also happens when I try to update the image.


Also, when I try to do getProductInfo() on these “glitched” dev products it will say these errors:


This is my code in local script:

local ProductInfo = mps:GetProductInfo(clone.Paid.PassID.Value,Enum.InfoType.Product)
					price.Amount.Text = tostring(ProductInfo.PriceInRobux)

		if Rselected ~= nil then
			local bought = game:GetService("ReplicatedStorage").Remotes.Gamepass:InvokeServer(Rselected.Name)

This is my code in server script:

local mps = game:GetService("MarketplaceService")

game:GetService("ReplicatedStorage").Remotes.Gamepass.OnServerInvoke = function(plr,selected)
	local val = game:GetService("ReplicatedStorage").Items:FindFirstChild(selected)
	local ProductInfo = mps:GetProductInfo(val.Paid.PassID.Value,Enum.InfoType.GamePass)
	mps.ProcessReceipt = function(recipientInfo)
		if plr == game.Players:GetPlayerByUserId(recipientInfo.PlayerId) then
			if recipientInfo.ProductId == val.Paid.PassID.Value then
				return Enum.ProductPurchaseDecision.PurchaseGranted

- note that these scripts aren’t finished, I was just testing for bugs and I found bugs so now I’m reporting

Thanks for reading this, any help would be much appreciated.

EDIT: Gamepasses also don’t work. And it says this item is not currently for sale when I try to buy it.

1 Like

That means your connection having an issue or the page is down or your image has been moderated.

To solve this issue, ensure your connection is stable and the page is not down. If it’s not solved yet, try to re-upload the dev products with the different image

1 Like

For some reason I can’t even create a dev product now…


Maybe you could clear your cookies only for the page where you’re going to create the dev products.

Nope, still won’t work.
I have cleared the cookies.

1 Like

Oh, the Roblox Dev page is currently down I guess.

So does that mean it was down yesterday too?
Cause it didn’t work yesterday.

1 Like

I don’t know tho. But let me check it out.

Try to upload random dev product and see if it works for you.

1 Like


It works very well for me.

So that means something is wrong on my end.

1 Like

I forgot something. Could you try that on different browsers like Microsoft Edge, Mozilla Firefox or something? It’s probably a browser bug that cannot upload things on a specific website.

Tried it on Chrome already (I’m using opera gx) it didn’t work.

1 Like

So, you have to remake the image and then re-upload the dev products. It’s the only way to solve the problem I guess.

It’s a misleading error message that occurs happens when the dev products name/image gets falsely moderated

I also tried using separate roblox account to upload dev products but it didn’t work.

1 Like

I used different images and none worked.

1 Like

Try to change the name of the dev product.

That works. I can change the name but the image.

1 Like