DevHub search feature yields indefinitely


#1

When I try to search something in the DevHub I get feedback saying that it’s loading the pages, but nothing happens at all.

This bug happens 100% of the time on 3 separate networks. All you need to do to reproduce it is to try to search for something and then hit enter.

The bug started happening yesterday.

I’m using Chrome browser on a Windows 10 PC.


DevHub at developer.roblox.com is loading some scripts over http
#2

Can confirm that this happens to me too.


#3

Seems to be working fine for me


#4

Was working fine for me last night while it didn’t work for multiple other people in the devforum discord server.


#5

This might be weird, but have you tried flushing your DNS cache? They moved the site recently, and I would be curious if that has caused issues.

Also the results I’m getting still link to “robloxdev” domain.

Edit: Never mind, it looks like they’re using a third-party search engine


#6

This should be fixed now. I manually invalidated a JS file that controlled the search that was incorrectly cached on our CDN. Can you all let me know if its up and working for you?


DevHub at developer.roblox.com is loading some scripts over http
#7

Yes it’s fixed for me now! Thanks! :grin:


#8

Still seems to be an issue. Had another friend try it as well but got the same result 3 hours ago. Checked again just now and still happening.
Happens no matter what Search term I am using.
Would a screenshot or video help describe it to someone? If so, post one.Screenshot%20(3)


#9

You might still have to clear your local browser cache. Chaching is weird since it’s done in various locations depending on the environment. Someone on Twitter had the same issue, and clearing local browser cache fixed it.

On Chrome, you can just press Shift+F5 to reload & clear cache for the given site you’re on.


#10

This issue was solved. Check above.

When going to developer.roblox.com, the search bar and search page do not work as expected. After following up on the warning chrome gave me about an unsafe script, it looks like a single script, located at http://dev-search.robloxdev.com/api/v1/public/engines/search.json is being loaded over http.

Here’s the popup and the error jQuery spits into the console:

image

If I click ‘Load unsafe scripts’ however, the site functions as it should.

Unrelated but still an issue

I also found this in the console, which with my extremely shallow knowledge of js, looks like a font that is only allowed to be loaded onto robloxdev.com is not loading because of the new url of the DevHub.


#11

I’m getting this too, it’s pretty annoying as my browser always blocks it by default with no option to always load the script.


#12

Ah thanks, tried clearing my cache from my Command Prompt. Shift + F5 seems to have worked.

Doesn’t seem that the issue is ‘fixed’ if people still have the issue, does it? :slightly_frowning_face:


#13

It’s fixed in terms of what Roblox can do on their end. Local caches will automatically bust after some time