Device Emulator not opening

There is still a missing piece in here somewhere, I’ve been attempting to repro this with various versions of Studio with no luck, using Team Create, without Team Create, etc.

If anyone has a fixed set of repro steps, please let me know.

1 Like

I’ve had the same problem too. For some reason, just clicking on the button in the testing tap works better.

What you need to do is simply run the game (don’t even have to play it) just run and it should be fixed
image

Yeah this happens all the time for me, it only starts happening after a while (I haven’t pinned down the cause), whenever I relaunch studio the button starts working again, but only for a short while.

I used to think it only happened on mac os, because I never experienced this issue on my old windows pc, might be worth checking that

It’s happening seemingly randomly, like I was just clicking the device emulator button now, then unfocused the window for a few seconds, went back into the window and the button suddenly stopped working, I literally hadn’t done anything else

Happens to me when I open the moon animation plugin kinda confused what causes this.

I tried the plugin but the button stayed operational.

This bug happens to me too. I don’t know what causes it, happens randomly.

My experience with this bug seems to happen consistently when creating UI meaning for me having to reload studio just too see if it’s sizing is good for Mobile.

I hope this helps you detect the cause of this issue, personally it seems to be caused by the UI editor.

I think it’s caused from auto-saving, as people have said in this report already.

I disabled auto-saving a bit ago now and everything’s operational. Haven’t ran into the bug since then.

1 Like

What I’m wondering is if this button is the only thing broken or the alternatives are also dead:

  • The “Device” button in the Ribbon - Test / Emulation
  • If you add the Device button to the “Quick Access Toolbar” at the top left
  • If you add a Keyboard shortcut to Device in File / Advanced / Customize Shortcuts…

Thank you!

It is working. Clicking on this button 1 time also fixes the one in the top-right corner of the viewport. I’ll try other points if I encounter this bug again.

Edit:

Does the same thing as previous button.

I’m not sure but I think you are also not able to scroll with the scrollbar of the explorer tab if it makes an auto recovery file while scrolling. A lot of times my scrollbar gets stuck and I can’t use it anymore.

After experiencing it for a while now it seems to be caused by the green loading bar appearing at the bottom of Studio. This can appear when auto saving, or uploading assets to Roblox etc.

It’s fixed by opening & closing a script.

2 Likes

Thank you, that’s super useful. I’ll try to repro.

1 Like

Switching the tab and back again will restore the device emulator button functionality.