Device Emulator not opening

Reproduction Steps
Reproduction Steps:

  1. Open Studio
  2. Attempt to click the Device Emulation button

Expected Behavior
The Device Emulation opens and allows me to use it. When hovering over the button it doesn’t get darker either.

Actual Behavior
When clicking the Device Emulation it doesn’t open.

Issue Area: Studio
Issue Type: Display
Impact: Moderate
Frequency: Constantly
Date First Experienced: 2022-02-15 00:02:00 (+11:00)


Works fine on my end

You might need to add a gif/video of how you are reproducing it, there’s little detail here for engineers to try and reproduce.

1 Like

I don’t think me providing a video on clicking a button would help.
Just seems like some sort of bug on my end and I can’t really do anything to fix it, I’ve reinstalled studio and have tried opening it on other places but no luck. Seems to work fine when I switch to my laptop though.

1 Like

This is happening to me regularly and is really quite frustrating as this button is vital for any sort of UI development.

Unfortunately I can’t find any easy way to reproduce it. The button works at first but as time passes it breaks until I reopen studio. Studio has team create enabled.


You can’t toggle the Emulator button while playing the game.

I wasn’t playing the game . . .


After trawling through Studio logs and trying a few things I’ve managed to figure out that this is likely the error arising from the button not functioning whenever clicked.

I’ve taken out a few numbers in case they’re sensitive. Message me for the full error.

2022-03-01T13:18:07.342Z,2012.342285,77e4,12 [DFLog::HttpTraceError] HttpResponse(#3140 0000020ED53A5260) time:155.1ms (net:155.0ms callback:0.0ms timeInRetryQueue:0.0ms)status:400 Target and EventType parameters are required bodySize:11 url:"

It seems to be caused occasionally when an auto-recovery file is created and you’re either messing with GUI properties or using the emultor. This can be tested easily by changing the auto save rate in settings.

It only happens when a auto-recovery file is created.

1 Like

Confirmed same thing happens to me.

I’ve been noticing similar behavior myself - it seems to occur for me on every TeamCreate session I join - but doesn’t occur on those I initiate. It still functions via manual triggering in the Testing tab within studio, but having the button is far more convenient when testing.

1 Like

Hi, I had this problem too and the way I would solve this is either clicking play on the normal emulator and stopping it afterwards. If this doesn’t work then another thing I would do is reopen the place. Hope this solves the problem!

Alternatively, change your Studio settings to disable auto save.

Hello! Thanks for the report! Filed an internal ticket for it.


Just started to happen to me as well, I’ve turned off auto-save and it started working again.

Have we got any sort of update on this? Been over 3 weeks with no solution yet.

1 Like

This looks to be tracking image, and I don’t think it would be needed for the Device Emulator to work. If it is needed, that’s unusual.

This bug also happened to me recently.

a fix for this issue is still in progress. i’m sorry


Stopped working for all of my team (4 devs) today.

Still happening to me regularly, not sure what causes it, but it’s a real pain.

The current solution is opening a script and then closing it. This still shouldn’t happen, and it’s very frustrating!