Disable Desktop App on Mac?

Hi, I use ROBLOX on Mac. For the past couple months, I’ve been forced to use the desktop app with no option to disable it.

I assumed it was platform-wide and so decided not to look into it further. However, my friend, who’s based in the UK, is not required to use the app at all when on Mac.

The app has several drawbacks:

  • When opening an experience from the web, the app opens onto the homepage. This forces me to find the experience again.
  • Because of the above issue, I cannot join private games I have access to. I can circumvent it by favoriting the game on the web and finding it on the app through my favorites. This is not something I should be required to do with a “new-and-improved” desktop experience.
  • I cannot join experience private servers through links. It just launches to the app homepage.

My question is: am I able to disable this? If not, I think that should be added.

You can do the same solution on windows PCs.

I don’t have any of the bugs you have mentioned.

You can through the app, if you’re having this issue:

Click the “Servers” button. Then, select the server:

This does not work if you’ve been given a direct link and there’s no specific whitelist.

1 Like

Roblox has not implemented a direct link system yet as far as I know. Joining VIP servers should be possible through the above. RoPro is an exception.

Forgot to update this topic. I found a solution elsewhere on the devforum, and it had to do with me using Firefox.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.