Drafts do not work with PlayerScripts

Reproduction Steps
Two issues here:

Issue #1: Opening any player script immediately creates a draft.

If you try to discard a draft while a player script is open, Studio will make a new draft. In this video you can see I discard the CameraModule draft multiple times, but it is re-created each time. Only when I close the script does it actually allow the draft to be discarded

Issue #2 Version history diff checker incorrectly displays what has changed.

Expected Behavior
Issue #1 the draft should only be created when a change is made to the script

Issue #2 only changes to the script should be shown inside of player script diffs

Actual Behavior
Issue #1, Studio creates a full draft for it regardless if I have made any changes

Issue #2, In this video you can see I make a change to the CameraModule by adding a print statement. I then look at the diff and it shows the whole script “removed” and then “readded” at the bottom.

There is no work around really. Unless, if you have both versions of these drafts you can check their diffs on diffchecker.com.

Issue Area: Studio
Issue Type: Display
Impact: High
Frequency: Constantly
Date First Experienced: 2020-10-01 00:10:00 (-07:00)
Date Last Experienced: 2022-02-15 00:02:00 (-08:00)

This has been an issue with Studio ever since Drafts and Version History has been launched. Recently we were trying to see the changes we made inside of various player scripts. That’s not really possible to do inside of Studio because of these issues.

1 Like

Hey Usering, thanks for the report. Issue #2 looks like a symptom of Issue #1 as the script that’s being incorrectly added to drafts is the one you’re reporting as having issues with it’s diff.

Is Issue #1 consistently reproducible for any script within StarterPlayer? Does Issue #1 occur if you were to attempt to reproduce it in a new TeamCreate place (or any place other than the one shown in the screen recording)? I’m currently not able to reproduce in an empty TeamCreate place, let me know if you see the same. Thanks.

I tried in three separate team create enabled places and it happens in all of them. These places were existing development places with lots of code elsewhere. Also tried a new place I had just freshly enabled team create and collaborative editing. Most consistently happens opening the CameraModule script and modules under it.

Tried narrowing down the issue by removing all sub-modules under CameraModule one by one until it wouldn’t auto create the draft any more. Didn’t stop happening until CameraModule was fully singled out and I had removed half of its lines + committed that draft.

do you have any local FFlags set in your environment? or any new Beta Features related to script editor enabled?