Dragger QoL Improvements [Beta]

Could you take a video clip? I’ve set my settings this way and it works like I would expect: A very fine grid when not near the edge of the part, and snapping to the edge when near it.

i like the alt to disable snap grid
maybe add a way to only use that one feature
or just settings to disable some more of the features

will there be a way to disable snapping on UI for more finer control using the dragger?

plz make it so shift doesnt scale uniformly

This is what happens when you don’t allow people to rebind controls, and don’t give people enough options.

Fr, Its been annoying me cause I cant snap at all. Idk whats happening

The scale is interfearing with the snapping as show in the video, the shift key was pressed the entire time

Video:

3 Likes

I like the options in the menus, because you can controll how the dragger behaves.
I dislike the removal of shift to snap to parts. It’s so much slower to go to the menu and click “snap to parts” AND turn off “Snap to grid”. Shift was so convenient for me, especially when building precisce structures, but the removal made that much harder to do. I would love to see shift to snap to parts back!

2 Likes

I also want all snapping disabled if I uncheck it, for whatever reason, some snapping still remains.

I want to be able to rebind all of these keys. I want to be able to control this behavior, such as “snap to parts axis”, etc.

When a part is dragged across the yellow lines that randomly appears, it doesn’t respect the grid settings. It acts as if the grid is off. I would like it to respect the grid.

We don’t have an API method for plugins to determine if grid is enabled, or not, or I can’t find it. I found under StudioService we can find the GridSize, which is not enough.

There’s other numerous, glaring issues, but these are the worst. So far.

I have the same problem with this one

Not a big fan really, I tried to drag a SpawnLocation on top of a Cylinder but the SpawnLocation kept snapping onto the circumference of the Cylinder, had to disable this to make it work. I don’t know what is causing it or how to disable it, I checked all those snapping boxes off but it still happened.

There’s some improved cylinder snapping I’m turning on next Monday, hopefully that helps.

A couple updates:

  • Cylinder snapping is significantly improved. You can now snap a cylinder either by the center or edge regardless of what grid snap you have chosen.

  • You can now summon the handles (by holding Tab) to locked parts once again, in particular, you can summon to the Move handles to any location on the baseplate.

1 Like

Same thing has been happening with me, it’s so frustrating

Where to find the toggle to disable those stud lines on cursor hover over parts? Since theres no more way to disable that Dragger QOL Update

Right… its so frustrating. The snapping a few months ago was perfect and now it doesn’t even work at all :skull:

3 Likes

File > Studio Settings > Selection


Trying to drag a part onto the flat surface of a cylinder still appears to be impossible, my cursor was in the middle of the gray cylinder part, but the mesh part i was dragging (and it doesn’t matter what kind of part your trying to place) insists that it must be placed on the outer edge, at all costs, no exceptions, resistance is futile. You must make the cylinder a union, but after that, you need to turn turn collisions to box so that it can be placed centered without any unwanted rotation while align parts is enabled, but sometimes i still find myself using the align tool because for whatever reason, even when the two parts are the same size (i ran into this issue with the two parts pictured) they will not line up centered when dragged. BUT even after doing those steps, unioning creates another problem if your using a cylinder part (or any part at that) smaller than 0.05, the second part your trying to place on said union part will be placed on the selection box instead, as as unions seem to inconsistently have a minimum hitbox (or selection box?) size of 0.05 (see lower photo)
image

This is really the main paint point atm for this beta that i can think of, i do love the smooth rotation movement when using r and t, and several other features i won’t mention because this is already a lengthy post.

Gonna come back to this because I released an update with new keybinds recently.

This beta feature completely takes over the keybinds, using CTRL + 1-5 does not work because its impossible to detect any number inputs. Additionally, using the numpad also doesn’t work because for whatever reason the NumPad 3 & 5 keys are binded to studio functions and those keybinds can’t be changed.

I understand building plugins use plugin:Activate in that way, but like others suggested, we could just have a plugin:Activate(boolean) or even an entirely different API call.

The problem being that you your key event listener doesn’t get the “1” key press? I could make that work if you have a modifier key like Ctrl held (Though you’ll be out of luck if the user mapped the draggers back to Ctrl+#).