Dragging 2 or more parts on top of a rotated platform will repeatedly rotate them

When dragging any selection of two or more parts on top of a platform with a non-zero orientation, the orientation will be applied to the selection every time it’s dragged on top of the rotated platform, even if it was already on top of the platform. This also happens for models of 2 or more parts.

For example, this platform is rotated -30 degrees. Dragging the two parts on top of it will repeatedly rotate them -30 degrees.


image

YouSpinMeRightRound.rbxl (18.7 KB)

I noticed this happening today (Feb 20, 2020), but I’m not sure about yesterday or any earlier.
I’ve disabled all plugins and beta features and this still happens.

It looks like this is caused by this setting:
image

This is pretty annoying because I’m trying to place props on top of things but I can’t get the orientation of them to stay consistent because this happens every time I try to drag them the lazy way.

8 Likes

i cant repro it, is there any more information?

I can’t repro this either, even doing almost exactly the some mouse clicks you show in the video.

Are you sure you don’t have some left over legacy plugin that’s causing this? (one just dropped in the Plugins folder rather than installed through the current install process)

It looks like this is an issue with this setting:

image

Disabling this stops the weird behavior.
(To be honest I’m not even sure what this setting is supposed to do).

2 Likes

I can reproduce this on my end.

I figured out why this issue is happening on a high level.

If you drag using the Scale tool instead, it will show a bounding box around the dragged parts. You’ll notice that whenever you drag the parts it aligns that bounding box with the underlying part. However, when you release the mouse, it recalculates the bounding box, to be axis aligned again. Rinse and repeat and you get a somewhat random seeming shift every time you pick up and put down the selection.

1 Like

A fix for this is on the way. Turns out that this issue has existed since 2017, maybe you just never noticed it before because you’ve been working on mostly grid aligned parts.

1 Like

I’ve figured out what this setting does and it turns out it’s necessary for my workflow and life is unbearable without it (it’s so painful to move models around). I’m impressed I never noticed this issue until now. Huge thanks for looking into it.

The fix for this problem is now live.

1 Like