Effect Goes Away When I Test

Broken Tool

So I have made a Torch, and when the tool is in workspace it is completely fine. Then whenever I put the tool in StarterPack and test the tool the fire doesn’t show up. I have no idea why it might have been something that I have done wrong, but I can not figure out the reason why.


Has fire, but then in the next screenshot you will see the problem.

No fire, but everything else is fine:

If you need any type of better understanding here so basically in the workspace my torch works perfectly fine, but in the StarterPack the when I test the fire doesn’t show.

SIDE NOTE: I do not work very much with tools so it might be a stupid mistake of mine.

Thank you in advanced! :upside_down_face:

Is the fire welded to the rest of the torch?

1 Like

What do you mean? This is how my tool is setup:


As in, is there a weld between the “handle” and the “effects”?

Regardless, you could probably parent the effects to an attachment inside the handle, then position the attachment where the “effects” part would be.

I did this, but it didn’t work… I am not sure if I am stupid or something but idk.

Which of the two methods did you try?

This one I tried, but for some reason it doesn’t work.

Can you show me the workspace set up now?

Like I said I don’t work with tools much so I might have done something stupid.


Parent the effects to the Attachment, not the “Effects” part, then remove the part when you’ve done so.

1 Like

Thank you so much for your help. It worked! :upside_down_face: