Enabling TC and giving group members permissions causes games to become locked

I would mark this a critical bug, but I know I’d get berated for doing so :upside_down_face: Even though I believe this definitely warrants one

I’ve since made 2 separate places, and both have become basically locked (I can’t open them in studio at all)


Both these places are under a group I own. I turned TC, then gave permission to edit to a set group rank. And now, I cannot access either them (once I’ve closed studio after giving them access, I’m locked out forever)

None of my developers can access the places too.

How to recreate

  1. Create a place in group
  2. Open in studio, enable TC
  3. Go to perms, and allow a rank access to edit the place
  4. Close studio, leave it for like 10 minutes and try coming back

I’ve tried restarting my PC, as well as un-install/re-installing studio. Neither has worked. I fear this could cause massive problems to groups whose games could be completely locked from accessing.

This doesn’t seem to happen in my other places in the group, even though there is TC + perms on them. Maybe this is something new that’s popped up in the past week or so that’s causing this??


I had a similar bug, I contacted support but there is just answer me message template I ended up finding the solution to my problem. Go see your version of games and restore the version before strangely there is a second “version” created just after without you doing it and which is bugged
If you’re lucky this might solve your problem too

*Also try to download the file of your game if you having like a XML error is probably this


That worked, but as soon as I left the place it got corrupted again.

This shouldn’t be happening. I should be allowed to have TC + group perms on a place

1 Like

This is most likely a duplicate of the issue with the baseplate template getting moderated, which has nothing to do with permissions.

Try creating a baseplate, inserting a part or making some trivial edit, and publishing over the team create game slot.

1 Like

Try to publish a update of the game in the studio after reversed to the old version

Thanks for the report! We’ve filed a ticket to our internal database and we’ll follow up when we have an update for you.


This issue should now be resolved. Please try again and let us know if you continue to experience any issues.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.