EnvironmentalSpecularScale / Global Shadows with large Color3 Decal values causes blinding place-wide light that flashes repeatedly

Issue Type: Display
Impact: Low
Frequency: Constantly
Date First Experienced: 2021-03-19 00:03:00 (-04:00)
Date Last Experienced: 2021-04-28 17:04:00 (-04:00)

Reproduction Steps:
Have an invisible part with a decal, and use a high Color3 value on it, such as below.

This gives it the illusion of “glowing”.

Make sure either ShadowMap or Future lighting technology is selected, and that EnvironmentSpecularScale is set to 1 alongside GlobalShadows being true.

While play testing directly in studio, the place will randomly light up in that decal’s Color3 value. This also happens during Team Test as well. This does not happen while building or scripting in studio.

There isn’t a concrete 100% reproducible way to make this happen, but more often than not this seems to happen only in large or memory-intensive places. Happens with and without plugins.

While it should happen to any large place, here’s a group place we’ve been working on that it happens on as an example. Press ‘C’ to fly around (and to spawn the asset that causes this problem). Confirmed to also happen in my other places using the same asset.

Here is the source file for the asset that has the large decal Color3 values. Press C on your keyboard to fly around, but you probably won’t encounter the glitch here unless you insert it in a memory-intensive place like above.
Workaround.rbxl (41.4 KB)

Expected Behavior:
Studio Playtests should not exhibit any lighting changes (especially ones that are blinding!). The colours should stay neutral.

Actual Behavior:
Here are a few proof pictures and footage of it happening in real-time:

This asset was made 1 - 2 years ago and only recently did this issue come up so I suspect a lighting change in mid-March started this problem.


Few options for a workaround:

  1. Leave EnvironmentSpecularScale to 0
  2. Turn Global Shadows off
  3. Don’t use such high Color3 values on a decal
  4. Rotating or moving my camera around seems to make the light fade away temporarily

If you are going to use uncapped color3 values for emissive textures, don’t set it that high, setting it to around 900 to 2k is good enough. Color values higher than that will cause rendering issues.


Just to note, this is unsupported behavior so the onus is on you to fix it in your games. Setting any property related to rendering to absurd values will of course likely have unintended consequences.


I am actually curious if the glowing effect that occurs when you set decals to a high value is actually intended. I wasn’t aware of this before. If it is, this just opened up some new possibilities for my game’s design! Just worried it might get changed in some way.

I’m assuming it has something to do with the HDR update they did a while back.

1 Like

It’s not intended and in the post I specified that it only happens during studio playtests so I wouldn’t rely on making it work in actual games.

This red effect still also slightly shows up even when the color3 value is set to 300 - 500, so its still a little annoying.

You’re saying the glow does not occur at all in the Player? I’m not talking about the rendering bug here by the way. But I thought the glow had something to do with the Future is Bright update.

Oops, misread your post. Still, the color3 being allowed to be set high- as far as I know, was and still is an unintentional feature. You can basically invert or enlarge a color3 value to pretty absurd values, which is how people do pretty funky effects with lighting for example, or make lava cracks glow. It’s pretty cool but again, it’s not intended and things like the rendering bug will always accompany it. It will work in the game setting in this case.

Hello! As mentioned, setting color values above 255 is not officially supported.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.