Equipping gear breaks idle pose in avatar thumbnails

Reproduction Steps

Currently, as of 7/15/22, equipping gears breaks your idle pose in avatar thumbnails, and instead causes the avatar to t-pose.

Steps to reproduce:

  1. Equip any gear
  2. Observe that your avatar is now t-posed in any avatar render on the site

Expected Behavior

It is expected that equipping gear would not break your avatar’s pose in the thumbnail renders on the site.

Previously, this issue only occurred with certain gear items, now it occurs with all gear items.

Before this issue started occuring:
NobleDraconian-2022

After this issue started occuring:
image

Actual Behavior

The avatar t-poses in thumbnail renders if a gear is being held.

Workaround

None

Issue Area: Roblox Website
Page URL: Roblox
Impact: High
Frequency: Constantly
Date First Experienced: 2022-07-15 00:07:00 (-04:00)

8 Likes

This doesn’t happen with all gear, just gear that has a Keyframe named “ThumbnailPose” inside the Tool object.

A little over a week ago they finally fixed the years-long issue where gear without a custom thumbnail pose would reset R15 characters to a default un-animated state in avatar thumbnails. For some reason, gear that does have a custom thumbnail pose is now experiencing this issue. (but the gear’s thumbnail pose still works)

Note: Most gear with a custom thumbnail pose just animated the right arm to appear outstretched, nothing fancy. This allowed the gear item to be properly held with your R15 idle pose, before Roblox finally added support for that.

I tried a couple of pieces of gear and didn’t get any problems. Can you let me know the IDs of some pieces of gear that you had this problem with?

1 Like

Here are two gears, said by Xyra the problem seems to only occur with gears that have the “ThumbnailPose” if that helps.


What it looks like:

image

in your original example, you have a piece of gear that looks like a red diamond. Do you have the id for that?

2 Likes

That wasn’t developerbet, that was me! :joy:

Here’s the link : Scrooge McDuck’s Giant Ruby - Roblox

1 Like

I’m currently experiencing a similar issue today. Instead of my right arm holding out the gear in sync with my currently equipped idle animation, it became stiff and did the same pose (old pose) as after the issue started occurring on the 15th.

I also realized a related issue on the 6th of this month when different gears that were absolutely in-sync with your idle animation (no right arm performances) were fixed to display right arm performance, however all of the other gears that were already fixed beforehand were now broken and display stiff animations.

Thoughts?

This appears to be fixed now! (For the gears I had issues with.)

image
image

It isn’t :
image

2 Likes

Noticing this as well, it only happens for some items:
image
image
Gear works fine for these items:
image
image

1 Like

Wearing Layered Clothing also seems to cause the problem as shown by Noble!

image
image

1 Like

Seems like Roblox reverted this change. The issue is now once again only happening to gear which doesn’t include a ThumbnailPose.

Most gear created in 2017 and onward include a ThumbnailPose. Older gear probably don’t, unless Roblox updated the specific gear item at some point within the last few years.

1 Like

Pose animations have never worked in 3D mode if you’re wearing layered clothing; this is not related nor is it anything new

Update as of 7/21/22 : Gear that has ThumbnailPose present works properly again:
image

HOWEVER, gear that doesn’t have ThumbnailPose present is broken again:
image

I’d like to add Dual Illumina to this list since well it’s a bit more than broken with R15 than R6

image

A lot of dual wielding gears suffer from this problem where they don’t connect to the other hand on R15

The Ruby causes this issue in 3D mode,

image

But not in 2D mode?

This is happening to my purchased gear Red Sparkle Time Claymore - Roblox as well.

image

This happened as I was equipping something for my avatar, It then broke the Idle and I couldn’t seem to get it back, there was when I found out It was a bug.

This is still an issue as of 8/5/5! Will this be fixed with Roblox’s upcoming avatar pose features?