Equipping something causes player to teleport

Hello, we have a system thats like Royale High’s where the player can equip different 3D Clothes on a custom rig. Such as bodices, skirts, hairs, shoes, etc.

However, for some reason equipping some of the skirts causes the player to be teleported to the part of the map where the skirt was placed before it was inserted into the inventory system.

Keep in mind: NOTHING is anchored, its all properly welded just as all the other items that work perfectly fine. So we aren’t sure whats causing the issue.

what we have tried so far:
-making the skirt massless
-Re welding completely
-Turning canCollide off
-Matching positions with a skirt that works fine
-Checking the scripts involved with equipping the skirt
-Everything is unanchored

Here’s a video:

We still have not yet figured this out. Please if anyone knows

@thirdtakeonit @Urukeli @crypto_mancer

Please could you guys take a look at this. I’ve been in contact with multiple experienced developers, community groups, etc and no one can figure out the issue which leads me to believe this is something with roblox’s engine.

This happens with heavy gears. Maybe it also applies to skirts. Try setting Massless to true.

We’ve tried. Doesnt work sadly

Still not figured it out. Someone please help