EquipTool() doesn't work anymore?

Hi, so for my game equip tool has always worked but for some reason today it just makes the player’s character teleport to where the tool is located in the world and then it apparently anchors both so that my character cannot move and is just in the sky with the weapon in hand.

This is so weird to me because this suddenly happened out of nowhere and I don’t know why, but I think it has to do with a recent Roblox update.

Anyone know how I can potentially fix this and get my game back in order? Thanks.


Isn’t your tool anchored/locked?

No, but I am using “perfectweld” but it doesn’t seem to be welding my tool anymore? Has it have something to do with welding?

I never got into welding. Can you show us the part where you call the EquipTool() function?

It’s WEIRD because nothing in my tool is anchored besides being welded to each other yet it still floats in the air like it IS being anchored. I’ve never seen this before in any Roblox games- is this a glitch? What’s going on??

It is happening while testing in Studio or while playing the game?

local char = player.Character

local tool = (workspace.Toolset:WaitForChild(toolName)):Clone()
tool.Parent = char
print("EQUPPING TOOL NOW OF NAME: " .. toolName)

That’s my code and it has always worked until recently. I don’t think it has to do with code personally, just the fact that my tool is anchored even though nothing is anchored.

I have no idea what may cause it then. Or it’s just a bug with studio/function or it is caused by a property enabled or set in one of the parts of tool.

I don’t know either but I find it bizzare how my tool is floating in the air like its anchored when its only welded to each other and apparently now its welded to the sky… How can an unanchored model act anchored? It makes no sense.

Yeah, it may just be a bug or temporary issue with anchoring/welding.

Hey! To get back to this… Is your tool at the same position all the time or does it move with you when you walk in your game?

I just don’t get why the tool acts anchored when its not anchored. I put the tool in another test place in studio and it acts fine, it drops and is welded. But in my main place it just sticks in the air like its anchored and it acts exactly anchored.

You haven’t answered my question with this… Anyways, try to rebuild the welds and also take a look at the weld positions.

I did answer your question indirectly many times as I have stated that the tool is stationary and acts as if it is anchored when I run the place. It has nothing also to do with welds I think because it works fine in one studio game and in this one it acts as if its anchored. The welds are all intact for both tests. Thanks.

Well, then I sadly can’t help you there if you’re trying to refuse to redo some steps…


The only reason I refuse to check the welds is because I have already tested the tool with the same welds in one place, and it drops onto the floor intact and the other game (my main game) where it stays in the air intact. This leads me to believe it has nothing to do with welds but some type of either studio error or internal machine error which is my new hypothesis.

I found out what was wrong for future people who might have the same issue… I had a weldscript in workspace that welded everything in relation to workspace so that made everything unanchored anchored. So watch out when you’re throwing around welds everywhere.

1 Like