Error 161 when Installing

Reproduction Steps

I recently messed around with doing a fresh re-install of studio (deleting all register keys and appdata associated).
Everything was fine, then I turned off my computer (windows 10). When I turned it back on to start studio, an update was auto-triggered and I’ve been getting this error ever since. I’ve tried uninstalling my current roblox, but the error still shows up on installation.

  • I do not have any antivirus software
  • I’ve got write permissions to my appdata, as it’s already properly written to most of the files.
  • I’ve tried installing as admin, and it doesn’t do anything.
  • I have enough free disk space on my drive in which I’m installing it on (at least 40gb).
  • I’ve tried re-installing several times.
  • I’ve restarted my Windows entirely and then tried installing.
  • I’ve tried installing with a VPN (people have sworn to me this might work), this also does nothing
  • Copying the entire install contents from someone else yields the same issue
  • Launching RobloxStudioBeta.exe directly says the file is corrupt
  • I’ve tried clearing all registry keys relating to roblox and then re-installing. This will cause roblox to work on initial install, but then triggers and update and then I get the same crash.
  • I’ve tried deleting the Roblox folder in the temp folder of %localappdata%
  • I’ve tried using an alt account
  • I’ve tried using an alt account in conjunction with a VPN after deleting my entire cache and registry keys and I still get the crash

I literally have no idea what to do, online searches yield nothing so far.

Edit: Looks like Studio Mod Manager works for now. Not an official solution, but at least I can work now. I believe it’s related to the fact that I’m enrolled in a test version of studio that this is being caused.

Expected Behavior

Roblox to properly install on my computer

Actual Behavior

Roblox crashes towards the end of the installation

Issue Area: Studio
Issue Type: Crashing
Impact: Critical
Frequency: Constantly
Date First Experienced: 2022-11-23 00:11:00 (-05:00)
A private message is associated with this bug report

3 Likes

I don’t understand this. What do you mean by “A private message is associated”?

some automated text, I just sent them some additional specs of my computer through a private message with the bug report.

Maybe corrupted studio. Try installing new.

I’ve re-installed several times

Have you got any antivirus programme?

I do not use any antivirus programs, Roblox Studio was working fine for me last night and mysteriously stopped installing properly without making any notable changes.

Whats your process for reinstalling?

I used Windows 10 add/remove programs to uninstall it initially. Then in later attempts I used the program Geek Uninstaller to make sure it did a full wipe uninstall. (since it’s not installing properly, traditional uninstallations no longer work)

For installing I just use to install exe from the site https://www.roblox.com/create

I found the solution, I had to delete register keys in HKeyCurrentUser/Software/Roblox along with deleting everything else and then installing. I also deleted the key …/Software/RobloxCorporation too just to be safe. And now I can properly install Roblox again.

I’m writing this down in case anyone else in the future needs this info.

Update, turns out closing and re-opening studio re-triggers the crash, guess this was not the solution.

Maybe it’s ISPO crash (too many users on internet), but it was only back in 2020…

that person who complained about that issue had no idea what they were talking about

Sorry y’all - this one was caused by a special build we put @aaron_mccoy on to attempt to debug a different issue. Should be resolved now.

2 Likes