Error 403: Asset is not approved for the requester

I created this image on Blender 2.93:

I exported it as .OBJ.
When importing in Studio, I get:

Asset id rbxassetid://6962835465 has too few triangles for renderFidelity to be set to Automatic or Performance
Image failed to load. Error 403: Asset is not approved for the requester


However, it was working some hours ago.

What’s wrong?


  1. Create a new BasePlate
  2. Create a new MeshPart
  3. Import these files (unzip first) to the MeshPart (MeshId parameter) (794 Bytes)


If I remove the material (texture) in Blender and export the object with no textures, Studio imports the (blank) object with no errors.
If I change to another texture, no errors too.

So, the problem is with the texture! :point_left:

Edit 2

Replacing the original PNG texture for the same image in JPG format in the object in Blender and exporting it again, Studio accepts the image…

Here the same OBJ using a JPG image instead of PNG:
esteira (795 Bytes)


1 Like

Change the renderfedility to Precise.

1 Like

Is this due to the asset still being reviewed by moderation?

1 Like

No, it’s because your asset has very low triangles and is not qualified to be simplified further by the Roblox engine. It needs to be set to precise.

1 Like

The RenderFidelity property of this MeshPart is already Precise, it’s the default.
However, I still receive this error.

1 Like

I uploaded the original .OBJ and .MTL in the original post (Repro)

I don’t know much about this bug. But one thing I do know about the warning is it happens sometimes when you press the plus button in the Toolbox on certain models and then when you look at the Output, it shows the warning.

1 Like

In the world of web development (and hopefully/probably Roblox), HTTP error 403 means “Forbidden” as in you do not have access to this file. If the model/texture is still in the moderation queue that may be the reason for this happening. Just a thought.

I second this post, it happens for more than meshes so I think it may be due to content moderation.

Happens with an image label:

Screen Shot 2021-06-23 at 1.15.04 AM

1 Like

I’m having the same issue… The model was fine for awhile, but when I reloaded my place to show someone, my log cabin textures are all removed with teh same error showing up. ugh, I worked hard on this thing…


Okay, I just tried importing a simple Cube from Blender, using a pallete file I’ve used for everything else in my game with no problems, for the past 10 months of development, but as of 11pm Eastern Time, July 3rd, I’m also getting these errors.


I resized my palette file from 256x256 to 200x200. This messed up the resolution a bit, but after resetting my new model to use this for the Input Texture, I was able to successfully get the model texture to be accepted… at least for now, without the error. But on my previous attempt, the error came hours, later, after I had imported it into the game… One thing that’s different - I took all the parts and combined them in blender, as it was a low poly model, anyway, and maybe this will help.

I’m not sure why the original was hit with this error anyway, and I have several important assets all using this 256x256 pallet, and hope I don’t have to go back into all those models and edit them. I guess that’s AI, most likely causing these issues for everyone, once in awhile.

Try changing your Input Texture (if that’s what you’re using) - resize it a bit or something. This ended up working for me.

If your original texture is PNG, have you tried to create a same texture but with JPG? As I posted in my OP, this solved the problem for me… and yes, it’s a bug.

The reason for that is because it gets re-moderated. If you upload the same image, it gets approved/declined instantly (depending on if the original image was approved or not) whereas changing the file format is a new image.

I can’t really test out your solution as I had it manually approved by sending a message to mod review requests.

1 Like

For images that are wrongly denied by the ROBLOX system, you can go to photo-pea, simply “auto-contrast” the image (It will mostly change less than 1% of your image; changes are usually too subtle to notice), then reupload the edited image. It should bypass the system 99% of the time.

You don’t need to do anything involved like that – just change one pixel’s color in the image slightly. Any change at all will change the hash of the file contents, so it will be re-moderated.

1 Like

In case anyone doesn’t want to convert their image to JPG, I had a same error thrown and stumbled upon this thread which led me to discovering a solution that worked for me. Inside GIMP I changed the color very slightly, and exported the image without metadata. Then I removed the old image from my game, restarted studio, uploaded the “new” image and it worked. I think there were some words in my metadata that Roblox moderates. Lol

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.