"Error uploading all UGC body parts"

So i’m trying to upload a UGC body… I’ve done it before with success, but this time it keeps giving me the error message of “error uploading all UGC body parts.”

All the checks passed correctly, i set everything up properly, i completely made sure to do EVERYTHING RIGHT, and i even restarted studio and re-imported the model over and over again to no avail. I’ve even tried tweaking the meshes themselves before reimport, but no dice.

No errors are showing up in the output either…

I can upload heads perfectly fine, just not bodies. and believe me, i’ve tried uploading different bodies.

What’s going on?


Having the same issue here, if anyone has any ideas that would be great

1 Like

Same here. Not on every item, but it’s not clear why we see it on some

We found a fix, you might want to rework or completely replace some of the caging around your UGC body. We used a default template file cage and just reworked that and it worked

1 Like

That’s what I did, but it turns out that for some unknown reason i had to re-do the foot caging. I always make the cages based on the templates roblox provides, just modifying them and keeping the UV’s intact.

So really it was a simple issue that was more confusing due to the lack of any error notices or anything being indicated.

I guess it just goes to show how absolutely careful you have to be with the cagemeshes… heh.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.