'Error while proccessing packet' Error in old snowboard gear

Hey devfourm, I’m currently trying to fix a old snowboard gear by ROBLOX for a remake of a Winter Games 2014 game known as Snowblox.

  1. What do you want to achieve?
    I want to fix a old snowboard gear for a possible remake of the old Snowblox game from the Winter Games 2014 event since the original game is currently broken due to 3 years of not being touched.

  2. What is the issue?
    I’ve made it so the snowboard (SkateboardPlatform, I’m aware the object is old and shouldn’t be used, but I suck at making alternatives) parents itself to the player’s character model to fix a issue where it doesn’t work when the two aren’t in the same model. Now the issue I’m having is that whenever I step on it, the client disconnects with the following error message:



I think the issue may be caused by a part of the old code (in a LocalScript which the skateboard runs on), but I’m not too sure. I also don’t know what line or block of code is causing this.

  1. What solutions have you tried so far?
    I’ve tried looking up the line “Error while processing packet” and “Packet ID 131 error” but I can’t find anything. Then again, I’m still not that great at scripting and new on devfourm.

I’m trying to fix the bug without breaking the functionality of the snowboard, if you wish to investigate yourself, here’s a quick model I made for those who want to look inside the scripts. Or steal it for your own game too, that’s fine by me, the original gear was made by roblox after all so I don’t own it.

If anyone knows what may be causing the issue, sharing that knowledge would be greatly appreciated!

Thanks, RGames1234

Have you updated the scripts on the snowboard to make it functional again? The error you get is telling you that the script is trying to set the parent of the Player to the Player. No gonna work.

If you have updated the scripts, I would recommend searching for any .parent in the scripts under the snowboard, local & server. Make sure that what you are parenting is the correct object/instance.

1 Like

Here’s the issue, I can’t seem to find a line in the code that is causing it.
Either there’s something weird going on with the code, or I’m just blind.
If you want a look at the code, let me know.

Certainly. Please make sure that you enclose it within the 3 ticks ```

Sorry for bumping this thread. I’m writing this for those who might come across this problem and wonder what’s happening.

I think all of this comes down to the way SkateboardPlatforms are coded internally, as the output says, your client (or the server, not really sure here) attempts to set your character model’s parent to itself.

Usually doing this will be caught by the engine and will result in a regular error, however it seems that in this case there are no checks for that, and the server (or the client, again, not 100% sure here) freaks out and kicks you out of the game.

That happens when you try to get on the SkateboardPlatform while its parented directly to your character.

Why this happens? From what I could understand, original Skateboards were stored in a Model and once you get on the SkateboardPlatform, that model’s parents gets set to your character’s model.

Internally, the SkateboardPlatform probably gets its parent (usually the board model, but in this case your own character model) and attempts to set its parent to the rider’s character model. (You can probably see how this goes wrong)

Since SkateboardPlatforms are deprecated and aren’t used nowadays, this is not a major problem, however, certain developers (myself included lol) might exploit this little gap in the system to kick players with the message “There was a problem receiving data, please reconnect.”