Every time I make a gamepass, it has the same ID as decals from 2008

I make the gamepass, and when it uploads it has the same ID as a decal from 2008. I cannot make gamepasses because of this. This is under a group place.

Every time, simply make a gamepass and press configure, then it takes you to the ID’s page.

It happens on the main site.


I’m not sure when the bug started happening, it’s been like it all day for me though.


There’s now a new gamepass system which has new ID’s:

This is probably why :smiley:

Edit: Lol wow, we all posted the exact same thing at the same time haha


Wait, so if you try configuring the game pass from that page, it takes you to the page to configure a really old Decal? I’m not sure if I’m understanding this correctly. That’s a bug if it’s doing that, but gamepasses do indeed have their own IDs now.

1 Like

Yeah that’s what was happening, but it seems to have fixed itself after happening a couple of times. I was really confused when I clicked configure gamepass and it took me to a decal of a scary pumpkin.

1 Like

I mean I witnessed this happen, we’re in a discord call, but on the group game undergamepasses I clicked the + icon it redirected me I tried it and then it prompted me for the right page… Anyways when i go to create/develope page and go to group gamepasses for me it wasn’t showing anything. Instead I get message “No public games to display game passes for.” … Not sure if its because we have the group game set to private or what, but the gamepasses are definitely for sell. (I’m guessing dan had went to the same page via the same method and had gamepasses showen and tried to edit there with a redirect… Honestly I was confused when he said to me that it was redirecting to a 2008 decal… #Whonoes)

1 Like

I think I know why this happens.

Take this gamepass for example, it’s link is https://www.roblox.com/game-pass/4793491/Donation.

By clicking “Configure” from the gamepass page, it works as it should, taking me to https://www.roblox.com/game-pass/configure?id=4793491.

However, when I configure it from the Create page, it takes me to https://www.roblox.com/My/Item.aspx?ID=4793491, which then redirects to this decal, a decal with the same asset ID as the gamepass ID.

I’m not sure if the decal would be SFW considering the name of it, click at own risk. It’s content deleted though.


Sorry for bumping this, but i’m now getting an issue where the gamepass ID is not recognised because it has the same ID as something from the library, when using :PlayerHasPass it says the ID is “not of type gamepass” and tells me to use :PlayerOwnsAsset but when I do that the game doesn’t recognise that it is a game pass.

It’s really halting development on my game as the rest of it’s done. It’s just these problems.

This should help. This is the replacement for PlayerHasPass

We figured it out, apparently it’s now MarketplaceService:UserOwnsGamePassAsync()

Thanks for the reply though!

1 Like