Everything inside of Model disappears when i hit play [PLEASE HELP!]

  • What are you attempting to achieve? (Keep it simple and clear)
    I am trying to set the player’s camera to a part’s cframe
  • What is the issue? (Keep it simple and clear - Include screenshots/videos/GIFs if possible)
    everything inside the model of the part disappears when i hit play. It does not disappear on the server
    This is the model.
  • What solutions have you tried so far? (Have you searched for solutions through the Roblox Wiki yet?)
    I have tried to find a solution everywhere but nothing seems to work.
    You may then include any further details.

There is no script deleting it and everything inside the model is anchored.

Anything helps.

1 Like

Are there any scripts that are unanchoring the parts?

1 Like

Nope, there isn’t a script that interacts with the model it just disappears by itself.

The parts are probably all just unanchored

As i mentioned in the post, all parts are anchored.

If theres no sctipts for the part then the model should be visible on the clients. Where is your model stored? If its in workspace it should be ok. Anywhere else this may be whats causing the issue depending on where.

Is the model far away from the character? If so then i think it’s due to StreamingEnabled not rendering the model because of you being far from it

try turning off Workspace StreamingEnabled

Thank you so much! I finally fixed it.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.