Experimental Mode [possibly] Still Forcefully Turns On For Universes With Newly Created Places


A few months ago, I noticed that going into a server on Xbox that had around 24 PC players out of 32 max, yielded no players except for people playing on Xbox, which was around 8. This is a problem that might be related to experimental mode, as teleporting to each place individually by a developer or a player, fixes the problem. Leaving this bug in, however, acts as a safeguard when it comes to PC & Xbox players playing a first-person-shooter, which just so happens to be what my game is. This is a bug that might very well have been fixed recently, but I’m not entirely sure. @Seranok requested I make this thread to hopefully have it resolved, if the bug still exists. I’m currently unable to test it myself.

Repro steps:

  1. Create a new game / universe
  2. Under game settings, turn “ExperimentalMode” off
  3. In studio, add a few extra places to the newly created universe
  4. Publish the test-game
  5. Have a few of your friends or players start up a server on PC, with extra slots for more players
  6. Have a couple of your friends with Xboxes and mobile devices attempt to join the server
  7. See if all three players are playing on the same server, if not, the bug is still prevalent.
  8. If step 7 returns as all platforms are playing on separate servers that only those platforms can play on, proceed to teleport yourself or someone else to each place within the universe
  9. After doing step 8, you should be able to have all three platforms playing on the same server