Extremely glitched drive seat

Hi guys, as you can see in the video, the car works fine, the chassis as well everything’s good, but when SEATING the player into the car, the car glitches a lot and flies aways.

(It’s not a CHASSIS issue, it’s just the seat, when you seat a player it flies away, (when pulling it out of the ground it works fine))

Perhaps the player is colliding with the vehicle. Try using collision groups or make most of the car non-collidable around the vehicle seat.

Well, I tried that, now it doesn’t goes UNDER ground but yes shakes and flippes

Does this happen if you don’t use the :Sit function? Are you calling it locally or in the server?

On the server, and yes, :sit causes this.

Ok, does it happen if you just walk into the vehicle seat?

1 Like

Haven’t tried, either way I need it to use :sit

I’m asking you to try it so I can help you figure out the issue. (Also, can you player collide with the car still?) My guess is it’s still colliding with the player somehow or creating some weird weld issue between the player’s character and the vehicle seat.

There’s no point on trying it, seat is disabled at all cost, so I just need :sit to work.

My guess is the parts are somehow colliding too much with each other and its difficult to find which I think you can try removing the parts around the seat manually and try sitting in it each time and see which part is causing the issue or try removing a bunch of parts and see if its working and sorry this might just be a dumb idea

1 Like

Yes, this is normally the exact cause of this issue.

Well, hey no, I tried everything and nope, the car still flies around :man_shrugging:

Car collision is literally off, it can’t collide with anything.

try removing parts manually and sit in it every time and find out whats causing the issue first , if it doesnt work try re angling some parts

Can’t do that, all parts are essential for the Model.
And the parts that are related to the chassis can’t collide

Have you tried teleporting the player to the seat and then using :Sit()?

Hmm, no, but pretty sure that :Sit already does that, doesn’t it?

Can someone help please?
It’s still not working :c