Faces inverted, but the faces are correct on blender

here is my mesh in roblox studio:
usually i would just invert this to the correct direction in blender, but with the face orientation, it tells me the faces are already inverted right:


how do i fix this?

also - the face that is invisible on studio is not even a face i have in blender, the faces i have are not triangle like

Did you try turning on the double sided property in the mesh properties? I can not guarantee it will work but it usually helps fill up the holes on my meshes.


Possibly add more edges around the corners where the object bends, I had a similar issue when creating a object with inset curves where the solution was to add more edges to support it. Additionally, the topology on the edge could be better.

maybe try triangulating the mesh in blender

Shift + N in Blender will recalculate the normals and should fix this.

I also recommend turning ON Backface Culling, as that will make it look like it will in Roblox



turn on double sided in roblox studio on your mesh

yep i did, but sadly it did not work

1 Like

this worked thank you!!!

Turning on “double sided” does not solve the problem with your mesh, it just disguises it.
The backwards faces are still going to react to light the wrong way.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.