Failed to load animation - sanitized ID:

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Running animation when I press shift.

  2. What is the issue? Failed to load animation - sanitized ID: rbxassetid://4660391957 - Studio, I already have tools that does animations perfectly and it still gives this on the tools. My animation isnt that id but 14660391957.

  3. What solutions have you tried so far? Everything.

local plr = game.Players.LocalPlayer
repeat wait() until plr.Character
local char = plr.Character

local anim ="Animation")
anim.AnimationId = "rbxassetid://14660391957"
anim.Parent = script
local loadanim = char.Humanoid:LoadAnimation(anim)

inputService.InputBegan:Connect(function (key)
	if key.KeyCode == Enum.KeyCode.LeftShift or key.KeyCode == Enum.KeyCode.RightShift then
		if loadanim then

inputService.InputEnded:Connect(function (key)
	if key.KeyCode == Enum.KeyCode.LeftShift or key.KeyCode == Enum.KeyCode.RightShift then
		if loadanim then

I am having the same issues. Though some of my animations work, and some of them don’t. I didn’t use different code for these animations, it’s just a weird Roblox bug and they will have to fix it. Sorry but i can’t help. Hopefuly they fix it soon!


I think i figured it out, some rigs wont work while others work perfectly. The rigs can change from working to not working at a flip of a dime tho. If that rig doesnt work, it wont work agian.

1 Like

Thats good you figured it out!

1 Like

I tried doing the animation on a new rig and reposting it to Roblox, then restarted my roblox studio. It worked for me personally but I can’t say it for everyone else

1 Like

You can just restart roblox studio or wait a day, then the animations work agian.

I solved this by actually uploading it in the right place, I had uploaded the animation to a different group and not the group that actually had the place/game under it. Try re-uploading it correctly to solve the issue

I dont use groups and this happens.

Then you’re probably not using your own animation… Is the animation ID that’s being used your own personally uploaded animation?

Having same issues on MOST of my games. happens in studio AND in-game… pretty much everyone of my games is broken right now due to this…

Staff really needs to work on this Immediately as it is effecting pretty much everyone.

I noticed the Sanitized ID it shows is just the regular ID without the First Digit… not sure what this means though.

Issue’s still happening, they really need to address it.

I have the same issues, I made a sitting emote, so perfect exactly like MM2, even the head anim(this is my first) and roblox ruined the anim by making the feet go through the ground (when I tested it never went thru the ground) and once the animation YOU made don’t work properly roblox sanitizes it idk