Failed to load animation - sanitized ID

m working in other’s game but their animation not loaded in stuido
I joined their group and got team create also but didnt work

ex)
Failed to load animation - sanitized ID: rbxassetid://15729849777

There’re many animations but everything not worked with that error.
But those animations of dummy showing well, only animations in character not
What should I do?

3 Likes

It’s because the group needs to upload the animation.

2 Likes

Failed to load animation - sanitized ID: rbxassetid://16164866387
I brought it to studio but not worked. Should I get this in upper link? but it not for sale for 0 robux

2 Likes

Could you show me the code that you are using to load the animation?

1 Like
  local animation = Instance.new("Animation")
  animation.AnimationId = "http://www.roblox.com/Asset?ID=15899920040"

  local YourAnimationTrack = CurrentPlayer:FindFirstChild("Humanoid").Animator:LoadAnimation(animation)
  YourAnimationTrack.Priority = Enum.AnimationPriority.Action
  YourAnimationTrack:Play()
  YourAnimationTrack:AdjustSpeed(0)

http://www.roblox.com/Asset?ID=15899920040” should be ‘‘rbxassetid://15899920040’’

(sorry it took so long to reply, I was sleeping)

animation.AnimationId = "rbxassetid://15899920040"

Failed to load animation - sanitized ID: rbxassetid://15899920040 (x2)

It showing same error too
But in game, two types of script all working well strangely

Who uploaded the animation?

(30 letter limitaaaaaaaa)

Personally updated by the game’s owner (not me)
But I tested both someone and group as owner
then they all showed same error

This is strange; the code looks fine. You have permissions to the animation, so I am trying to figure out whats going on.

Ask the owner if the animation uploaded to the group works for him.

Anyone knows this situation? I still need help