Failed to load AnimationClipProviderService

Trying to play animations on my tool however I sometimes get “Failed to load AnimationClipProviderService” after respawning, causing my tools animations to not work.

I have tried the solution in this post already

I have no idea what is causing this.

This usually happens when you try loading an animation onto a character/model thats parent is nil. Make sure to load the animations when the characters parent isnt nil.

1 Like

Could you send the script that is causing this error?

this error also completely doomed me i just have no idea on how to fix this

One of the staff member said to use the waitforchild(“Animator”) in order to wait for the Animator to be replicated then play the animation.

i already fixed it but thanks character limit

How? I have the same issue here.

I found a fix that works for me:

local player = Players.LocalPlayer
local character = player.Character
if not character or not character.Parent then
	character = player.CharacterAdded:Wait()

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.