Failed to load entities for universe / game settings

Recently, I’ve noticed that in my game, Redshift Arena, I’m repeatedly getting HTTP 500 Server Errors, which results in me not being able to modify game settings, or view items within the Game explorer pane.

image

Edit


This also prevents me from modifying LinkedSources or uploading Images in Studio. This also applies exclusively to Redshift Arena as far as I know. Has been this way all week.

**Edit #2 **


New error just popped up, or I just caught onto this.
image

Edit #3


This has persisted for 2 weeks, and my game is being featured tomorrow. There’s a few bugs that I cannot fix currently due to this issue. I’m also unable to add levels to the universe, due to the option to do so being taken away earlier this year. A lot of my code is LinkedSource based, so I cannot edit 99% of my code, I also cannot add new images or create / update packages. I’ve attempted logging into an alt account of mine, trying another PC, uninstalling Studio / reinstalling it, etc. etc.

Nothing has worked so far.

Should also be noted that all of my code is still functional while in-game or in playtest.


TL;DR Version

Redshift Arena’s Game Explorer appears to be completely broken. Even though the error message claims it’s failing to obtain entities, scripts still run, images still load, and packages are still loaded. The Game Explorer acts as if none of the places within Redshift Arena’s universe are published, thus making it impossible to edit linkedsources, add new images, add / edit packages, or add new places.

Also, here is the error message that comes up:
image

2 Likes

Bumping this, as I’m still experiencing the problem.

1 Like

I’ve started experiencing a similar problem today, I am unable to open the game settings page in game. Sometimes the icon is there and I can click it but it is unresponsive and sometimes its completely grayed out and can’t be clicked. When I open studio I get a whole pile of error messages. I disabled all of my plugins but I still see these errors.

My games window is operational though:
image

While I’m not sure if this is related, it seems I also can no longer use the script found in the wiki to change default animations. This is probably because the animations are being set by game settings but of course I can’t access this to find out. Either way game settings shouldn’t override a script in game that sets the animations because I might want players to start with one set of animations but use a different set later on; but perhaps this is another topic.

3 Likes

We are actively working on a fix for the issue where game settings are inaccessible.

4 Likes

My models are not in the right order, but when I check my models that were already uploaded they are in the right order. Is this a new bug?

Bug part-

This shows up when I check my already uploaded models and it’s in order

Thanks for addressing this! :slight_smile:

Post has been updated to hopefully better reflect the issue.

This bug seems to have fixed itself after 2 1/2 weeks, or a member of Engineering has fixed it.

1 Like