Failed to upload union, Exceeded limit

Recently while trying to upload a map for a game, I got an error saying “Failed to upload union, Exceeded limit.”

Does anyone know how to fix it or bypass the limit? I really need to find a solution as remaking the map isn’t an option, Please let me know

  • Leo

Must be roblox issues, try again soon or restart studio

1 Like

I’ve been trying for a few days now, But I still get the same error.

So I had this problem about a year ago and it is extremely frustrating. What fixed the problem for me was removing any unions created during 2019 or earlier. Roblox randomly changes how they handle unions over the years and it causes conflicts like this.


How many tris in your Union, and how big is it?
Unions are messy versions of MeshParts, so you may want to convert it to a Mesh to decrease the amound of tris.
Send an image of the Union(s) you are building.


The map is fairly new, unless Roblox did something in the past thew months I don’t think that would work.

There are multiple Unions, do you just want to know how many tris are in each or overall?

I’ll give this a try hopefully it works. The map is ginormous and full of unions, so it may decrease the amount of tris but maybe not quite enough.

Each union can vary, want a screenshot of all the unions together or just one?

Just wanted to know how many tris are in your Unions. I guess if you can create the Union it should be alright to upload.
I just wanted an image to get an idea of how many tris could be in it if you didn’t have that information.
Unions were limited to 5000 tris according to Solid Modeling | Roblox Creator Documentation, but I think I read somewhere that it’s been increased to 10000 (maybe that’s MeshParts, I could be wrong).

I somehow managed to figure out a way to fix the error:
for some reason, if you try to create and publish a new place with a map that has a lot of unions Roblox studio gives you an Error

While if you copy & paste your map into an existing place and then you publish it you get no error,

I don’t understand how or why but it fixed the problem for me


But, If I try copying a map, studio crashes.

1 Like

How are you copying it? If you try copying the place it errors, but if you open a new blank place then copy the contents of the first place and then Paste it into the new place it should work.

How many items (Parts/Unions/Meshes/Terrain etc.) are you trying to copy? If it’s too much stuff then of course you may have issues.

I did that, It lagged a bit, and then still gave me the same error,
you can help me by replying on my topic.

The reason this is going on is this:

Roblox studio has a set data limit that it allows uploading at any given time for every data file, unions in particular can be data heavy. When it say that your union has “Exceeded Limit” it means a union on the game has exceeded the threshold to send over to the server at the given moment. I have found that if you upload a game incrementally instead of all at once its less likely to error and you can debug what you did easier as well when the error does occur.

Incrementally just means as your making the map or item.

1 Like

Good answer.) It helped me.) There are a lot of elements in my game. And I just gradually downloaded each folder in my game and there was no mistake.)