FE GUN KIT Aimpoint Issue

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    Hi, I was trying to make an aimpoint for my gun using the FE GUN KIT system

  2. What is the issue? Include screenshots / videos if possible!
    For some reason whenever I try adding the aimpoint and weld it to the handle, it works but for some reason it goes slightly off and not actually go to the position of the aimpoint part. Its a bit hard to explain so heres an image below.

I was just trying to make the aimpoint work without having to pose it before.

default (the red square is the aimpoint part)

and heres when i aim down

(I’m not sure if it should be part of art design because it involves both animation and scripting)

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    As of now I’ve tried to see if the aimpoint would work if I posed it before I animate it because currently I’m using a blank rig without a pre-pose and it worked.

I also tried to see if it actually went off center and the camera just clipped past the aimpoint.

I also figured it might’ve been part of the arms changing position so I tried to look in the script if the arms moved but didn’t really change much.

Its probably not called a blank rig but thats all I know it as.

help would be strongly appreciated.


Hello, I’ve found rigging the weapon onto HumanoidRootPart within view-model resolved this specific problem. HumanoidRootPart for both arms and weapon, instead of having gun connected to arm.

hey dev branch thanks for your reply, this post is from 6 months ago and the problem i had has been resolved;

the rig i used in that screenshot was rigged by connecting the arms and gun to the humanoidrootpart and positioned the gun/handle on the arms. i don’t think it would resolve the problem because it is only regarding the weapon and arm.