"File > New creates a place with Team Create off" Has No Effect

Reproduction Steps

In File > Studio Settings, search for “File > New creates a place with Team Create off” and enable it. Then create a new place using File > New. Instead of creating a baseplate that can be saved locally, it will create a new place with Team Create active.

Expected Behavior

The “File > New creates a place with Team Create off” for the last few releases allowed for creating local Baseplate files (mainly to be the equivalent of scratch files but for Roblox).

Actual Behavior

A Baseplate is always opened as a new place entry with Team Create enabled.

Workaround

The only obvious workaround I can find is to have a local file and open it. There is no way to do it in Studio and to have a Baseplate without already having a local file for it. Not having an empty template for a quick test or working on a system before integrating into a game is now hard.

Issue Area: Studio
Issue Type: Other
Impact: High
Frequency: Constantly
Date First Experienced: 2023-01-19 00:01:00 (-05:00)
Date Last Experienced: 2023-01-21 00:01:00 (-05:00)

5 Likes

Do you have the “New experiences enable Team Create” beta feature enabled? For me, everything works as expected when it’s disabled.

1 Like

That appears to be the case. Guess that means the setting became effective if and only if you have the beta feature enabled.

Hello, we’ve been working on the settings related to this beta for this a bit and that is an old about-to-be-removed setting that no longer does anything.

That functionality has been merged with the “Display Team Create toggle when creating a new experience” which now controls both showing the toggle as well as making “File > New” be non-team-create. We’ll have an announcement with more information about these changes coming soon.

2 Likes