Find All returns code from CoreGui

Try searching Humanoid in Find All, there will be 570 results all from the CoreGui and not a single result is useful information for developers. Results from CoreGui should not appear in this window

image

4 Likes

Do you have the setting, “Show Core GUI in Explorer while playing” enabled? If you do, this seems to be what’s causing those results to show.

How are you reproducing this issue? I’m not getting any CoreGui results with both the Show CoreGui and Show Hidden Objects enabled. This is why the bug format exists, anyhow.

In Studio:

image

In a play solo session:

image

Expanded Explorer view:

Studio settings:

image

1 Like

I had the same issue, it looks like you have to clear the search bar for it to update.

Oh, got it as well. I had to open a completely new Studio file though, the results weren’t showing up by re-searching the terms or reopening the widget.

image

Yeah, not very helpful to have these here lol.

2 Likes

You can avoid this by unchecking “Show Hidden Objects” in Studio Settings >Studio>Explorer

The underlying logic of Find All/Replace All is searching all scripts shown in your Explorer. By default, hidden objects should not be shown.

4 Likes

This is not an acceptable solution. This is a workaround until a proper fix is introduced. There are many developers, like me, who use the CoreGui scripts as a reference when doing certain things (like VR), and having to constantly toggle this option to avoid every search being cluttered is an absolute chore.

There are both times when I want to search CoreGui scripts and times when I don’t want to. Having this be tied to Explorer visibility is too inconvenient.

1 Like