First person to load into reserve server is stuck viewing workspace and not loading in

Reproduction Steps
Join game - > [UPDATE] All Star Tower Defense - Roblox

Go to any of the missions that teleport you to reserve server [story mode, infinite mode]

Make sure your teleporting with other people [get other people in your elevator]

First person to load into the reserved server after teleport [btw this glitch doesn’t work when teleporting alone] will be stuck in a view like this

Expected Behavior
The person to load in and spawn in

Actual Behavior
They are stuck viewing the game as if workspace is still loading in

Issue Area: Engine
Issue Type: Display
Impact: Very High
Frequency: Constantly
Date First Experienced: 2021-10-26 22:10:00 (-04:00)
Date Last Experienced: 2021-10-26 00:10:00 (-04:00)


Exact same thing is happening to me. Testing a game that teleports to a reserved server with 2 clients, and it’s always one client that has this issue. Things like the developer console are also broken during this bug.

Thank you for reporting this issue. We are currently investigating.

1 Like

We’re also experience this bug in our game.
Same repro, first player to join on ReservedServers

1 Like

For reference im using the old api


I don’t have a video but I do know that when it happens you can’t open dev console to see your client logs or any of that stuff

Yeah, our experience is also ‘experiencing’ this issue. As a game that relies solely on coop reserved servers, this is hitting us quite badly. Never seems to happen solo, and one player would be stuck on the loading screen.

Top screen: What another player sees of the disconnected player
Bottom Screen: What the glitched / disconnected user screen looks like

Users report this started happening today.

1 Like

Tried it with new api, still doesn’t work

This is massively affecting World // Zero as it relies on teleporting parties to dungeons

Hi Everyone we are really sorry for the inconveniences this has caused. We think we have fixed the issue, please let us know if you still see the issue.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.