[Fix] Blender Animations

NOTE

The original plugin was scripted and published by @Den_S
Original Plugin
All rights are reserved for the creator.

None of this is being used to gain profit or fame, this is only meant to help people.
This thread will remain open until the original plugin has been fixed, or if its creator,@Den_S, requests me to take this plugin and thread down.
Please read this carefully through, as in most cases, our method will work.

If you are new to this, please continue here:

For beginners

Note: Do NOT install the Roblox plugin as of its state right now, shown in the tutorial. This will break your rig when importing.

Blender rig exporter/animation importer

Introduction

Hello everyone! Recently I’ve seen many developers encountering an issue when importing rigs into blender using the Blender rig exporter/animation importer plugin developed by @Den_S.

Many people have been frustrated and unable to animate using blender because of this problem. With the help of 2 people, we have been able to create a temporary fix.

This tutorial is only about installing the fixed plugin and properly setting up rigs in blender.

This will work for one and multiple parts, meshes, whatsoever.

Bugs

If you are trying to animate, you probably encountered the same problem as shown in this video:

Pay close attention to the highlights shown in the video, what body part it chooses and what name it has:

Super weird right? Let’s get into the fixing for that.

Installation

Roblox Plugin - [REVERTED] Blender Animations - Roblox

Warning: Only use R6/R15 default template rigs, do not use with accessories, only the objects you want to animate.

Install the plugin, disable the original plugin to avoid confusion.
Just again to note that the current plugin is going to and will break your rig.

Fixing the bones

  1. IF you already pressed on “Rebuild Rig” then, the first thing you will need to do is, delete the “Rig”, so we can start to rename the bone parts to the belonging parts of your rig, to make it work.

  1. Click a bone of your rig, figure out which part it will highlight, double click to rename the bone, name it the same way as it is named in the Roblox studio rig. (for example; if the actual rig part inside of Roblox studio is called “Part123”, rename the bone inside of Blender to “Part123” and make sure to pick the right bone, so the animation will play when importing.)

  1. After you have renamed all of the bones, simply click “Rebuild rig”.

  1. Animate your rig, as you normally do. After you have animated it, simply hover to the “Export Animation” button and bake the animation. Import the animation inside of the script and have fun animating!

Outro

I hope this helped and satisfied you with the bug fix!
Last but not least I want to give out huge thanks to:

@Den_S Creator of this amazing plugin.
@HowsLifeJosh Providing us an older version of the plugin and showing the blender bone fix.
@2967k Research and Ideas.
@alteredberg Reverse Engineering code, general dummy fix.

And all the people that participated in the debugging!

Please leave a reply if you see any mistakes, this is my first time creating something like this.

Thank you and see you later!

28 Likes

You should probably read the entire post :man_facepalming:

2 Likes

I have used it and it still doesn’t work (I’m using Blender 3.1)

Random parts spawn and it will not let me select a body part.

you need to install the import [rbx animations] rig import (.obj) plugin for blender, you just imported the rig using the standard .obj setting

How come my model isn’t round when imported? The models limbs have no roundness - unlike the normal R6.

it works in certain version or supported
Consider changing to 2.91

1 Like

Thanks. I’m currently on 2.8. I will try it out when I have the chance.

I then used the plugin after all of this, still doesn’t work.

Importing doesn’t work for me. The script where u import the animation simply does not appear like it does in the normal plugin.

Went back and read the tutorial provided. For part 2: Renaming the objects rather than the bones before rebuilding works too. I hope the limbs can be renamed to their associated bones rather than renaming them manually eventually.

(didnt mean to reply to you woops)

Still doesn’t work…
And I can’t rotate it in the animation editor for whatever reason

1 Like


How can i fix this error?

4 Likes

getting the same error and I’m losing my mind. I’m gonna revert Blender to 2.8 to see if that works.

Turn off your team create. It fixed it for me…

Okay I fixed mine. Just download Blender 2.8 and youre going to need to reinstall the roblox plugin once you open up Blender.

easy to say but roblox enabled team create if you make a place and you can’t disable it

I’m pretty sure I was able to disable it somehow a few days ago…
But I can’t remember how… Also try to load in one of your old games
With no team create