[FIXED] Roblox Studio Stuck At Downloading at 50%?

Hi everyone! For a bit of background, I recently moved into a new house and I’m setting up things. Recently for whatever reason, it kept asking me to log into studio whenever I logged into it. I decided to delete it to see if that would work and now its just not reinstalling. Whenever I open the installer it just goes up to 50% then quits.

What I’ve Tried

  • Restarting my computer
  • Allow the app through firewall
  • Allowing the app as administrator
  • Deleting the Roblox/Roblox Studio folder in app data
  • Put the router in my room

If anyone can help please do! I would really appreciate it.

Try seeing what your ping and download speeds are with a website like speedtest.net.
If your speeds are ok have you tried uninstalling Studio instead of just deleting it?

I don’t even have the Roblox Studio Application anymore, so how would I uninstall it?

And I guess my low speeds are contributing to the fact I can’t reinstall but how would I get around it?

1 Like

So, after gaining a stronger connection, I was able to successfully download Roblox Studio. If anyone has this issue, the only solution is to gain a stronger internet connection. Thanks to @Scottifly for trying to help!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.